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PHAWorks 5.1 CHANGES (ITEMS IN RED ARE NEW FEATURES):

ARCHIVING

e In the “Archive Information” dialog, the “Comments” field now includes a vertical scroll bar.

AUTO COMPLETION
e Auto completion of entries has been fixed in the “Severity” and “Likelihood” columns.
COPY FROM OTHER PROJECT
o Comment status entries are now being copied between a What-If or What-I1f/Checklist and other
study types.
e The “Safeguards” column is now being numbered correctly when copying data between projects.
e Banner names are now being copied correctly between projects.
KEY
e Includes automatic activation feature.

PASSWORDS

e The “Passwords” menu now works correctly in the “Protect Task Center” for projects that don't
use global parameters.


http://www.primatech.com

PHAWorks 5.1 CHANGES cont. (ITEMS IN RED ARE NEW FEATURES):

QUICK ACCESS

e In some situations, “Quick Access” took you to the incorrect location. This has been fixed.

QUICK ENTRY LIST

e You were not able to create the “Global Quick Entry” list after first declining to create it. This has
been fixed.

REPORTS

The “Columns” page correctly displays the order of how the columns will be printed.

The “Classification” report correctly separates outs the values for “Risk before Rec”.
Deleting a custom report no longer makes PHAWorks unusable.

The “Statistical” report now counts items with different font attributes as the same value.
When increasing or decreasing the columns, it now affects all selected columns.

Filters dialog uses an updated interface.

RISK RANKING
e Risk Ranking no longer inserts extra zeros in the “Severity” and “Likelihood” columns.
SAVING / AUTO BACKUP
e When saving, PHAWorks now verifies the save succeeds prior to overwriting the old version. This
was added to eliminate the possibility of files that have become corrupted overwriting files that
have been saved correctly.
SESSION DIALOG
e When updating the “Session” dialog, no longer makes PHAWorks unusable.

e Date field includes a date-picker allowing you to select dates from a calendar.
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PHAWorks 5.05 CHANGES (ITEMS IN RED ARE NEW FEATURES):

ANALYSIS TOOLS

e The "Life Cycle of a Process" topic has been updated with current information.

ASSOCIATIONS

e The “Associations” dialog will not appear if you move between different PHAWorks related
programs or run the program from multiple locations.

DRAWINGS DIALOG

e The relevant drawings are now displayed correctly. In earlier versions, the relevant drawings
sometimes caused the project to become corrupted.

KEY

e If you activated the key on your hard disk, you can now move the key from one computer to
another using the “Move Activated Key” option in the program group.

PROGRAM

e Periods (".") can now be used as part of file names.
PROGRAM - VIEWER

e The “Worksheet Views” dialog now allows you to change views.

QUICK ENTRY

e You have an option of auto completing an entry in the worksheet. If the text that is typed into a
worksheet matches an entry in the “Quick Entry” list, the entry will be automatically completed.
This is a user option.

REPORTS

e If text splits across multiple pages, the parent entries are now repeated and use a (cont.) on the
following pages. This is a user option.

e |f an entry is split across two pages, an ellipsis is shown at the end of the entry of the printed
page and at the beginning of the same entry on the next printed page indicating the entry was
continued. This is a user option.

Partial lines of text in reports are no longer printed.
Under certain limited conditions, the ends of some worksheets were not being printed. This has
been corrected.

e The Protocol report was using incorrect titles. The Protocol report now uses "Protocol” for the
cover title and the corresponding protocol name for the title for each protocol that is printed.

e The "Filters" tab will now change to "Filters (on)" if using filters.



PHAWorks 5.05 CHANGES cont. (ITEMS IN RED ARE NEW FEATURES):
WORKSHEET

e Pasting data from a Word table no longer causes an “out of memory” error.
e The long date displays correctly with the session and revision fields in the banner.

WORKSHEET VIEWS

e The OK button is no longer grayed out if a view is invalid. If a view is invalid, PHAWorks will
automatically add the required parent column. If a view includes no columns, a warning
message will be displayed.

e In the “Worksheet Views” dialog, you can now order the columns in the worksheet in any order.

-- WARNING -- Once you save a project in PHAWorks 5.05 using a custom order from the
“Worksheet Views” dialog (not an order option in the “Column Configuration” dialog), the project
can no longer be opened in PHAWorks version 5.04 or earlier. You must use the column
configuration order for the project to be opened in these earlier versions.
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PHAWorks 5.04 CHANGES (ITEMS IN RED ARE NEW FEATURES):

CHECK FOR UPDATES

e A "Check for Updates..." menu has been added to the "Help" menu. This will check Primatech's
website and notify you if an upgrade of PHAWorks 5 is available.

COLUMNS

e The "Save as default for new projects" now works correctly when user-defined columns have
been added.

CREATING A NEW PHA

e When creating a new project, clicking YES to overwrite an existing project now works correctly.
EXPORT

e The hierarchical (outline) export format always uses the project's column order.
GUIDEWORD DIALOG

e The option to "Save as defaults for new projects" is now included in the Guideword dialog.

HELP

e The Guideword dialog help page has been updated to reflect the "Save as default for new
projects" capability.

e The Parameter dialog help page has been updated to reflect the "Save as default for new
projects" capability.

e In the help file, updated the "Contacting Primatech" topic references our new address -
Primatech Inc., 50 Northwoods Blvd., Columbus, OH 43235.

e Updated the "Contacting Primatech" dialog under the Help menu to reflect our new address -
Primatech Inc., 50 Northwoods Blvd., Columbus, OH 43235.

PARAMETER DIALOG
e The option to "Save as defaults for new projects” is now included in the Parameter dialog.
PROGRAM
e The current time is now always determined using the user's current time zone information
instead of using universal coordinated time.

e Changed the start-up "About Primatech" dialog to reflect "PHAWorks 5.04".
e Changed the "About Primatech" dialog accessed from the Help menu to reflect "PHAWorks 5.04".



PHAWorks 5.04 CHANGES cont. (ITEMS IN RED ARE NEW FEATURES):

PROGRAM - EVAL

Changed the "PHAWorks 5.0 Evaluation” in the program title bar to "PHAWorks Evaluation™.
Changed the footer in the reports to say "PHAWorks Evaluation by Primatech Inc."

Changed the start-up "About Primatech” dialog to say "PHAWorks 5.04".

Changed the "About Primatech" dialog accessed from the Help menu to reflect "PHAWorks 5.04".
Changed the start-up "About Primatech” dialog in the eval to say "PHAWorks Evaluation" in the
title bar.

e Changed the "About Primatech” dialog in the Eval accessed from the Help menu to reflect
"PHAWorks Evaluation" in the title bar.

PROGRAM - VIEWER

e In the PHAWorks Viewer, the Export command is no longer available in the Project Task Center.
e Changed the start-up "About Primatech" dialog in the PHAWorks Viewer to reflect "PHAWorks
5.04".
Changed the "About Primatech” dialog in the PHAWorks Viewer accessed from the Help menu to
reflect "PHAWorks 5.04".

PROJECT IDENTIFICATION DIALOG
e Project Identification data is no longer lost when the Project Notes are changed.
QUICK ENTRY
e Converting Global Quick Entry data from PHAWorks 4.x to PHAWorks 5 now works correctly.
REPORTS
e A multiple page index in a worksheet report now prints correctly.
e Fixed flickering of filters checkbox that occurred when filters were active but the cover page
checkbox was not selected on the report cover options page. This was only a visual problem and
did not affect the reports.
e Printing from preview now works correctly for the Individual Information Needs report.
e Fixed problem in HTML report generation where the worksheet output was terminated
prematurely under specific, unusual circumstances.
e Changed the report footer in the reports to say "PHAWorks by Primatech Inc."
UNDO
e Undo now works correctly after entering text using Quick Copy.

WORKSHEET

e After pasting text, the cursor is now located after the pasted text.
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PHAWorks 5.03a CHANGES (ITEMS IN RED ARE NEW FEATURES):
REPORTS

e Printing from preview using the Action Items report with filters now works correctly.
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PHAWorks 5.03 CHANGES (ITEMS IN RED ARE NEW FEATURES):

ACCELERATORS

e The warning messages concerning creating invalid accelerators has been updated.
e All default accelerators shipped with PHAWorks can now be assigned.

ARCHIVE

e A Project ID button has been added to the Archive Information and Archive Files dialogs.

AUTOMATIC NUMBERING

e If you change the Reference column numbering to use the REF# column, the software now
warns about the current REF# data being replaced.

e Recommendations can now be numbered using the node/system number as part of the
recommendation number. -- WARNING -- Once you save a project in PHAWorks 5.03 with this
capability, it can no longer be opened in PHAWorks version 5.02 or earlier. You must turn this
numbering option off for the project to be opened in these earlier versions.

BUG REPORT

e Submit Bug Report is now available in the Help menu to help you provide information to
Primatech concerning any software problems you may encounter in PHAWorks.

COLUMNS

e You can now change all the column names by selecting Column Names under the Project menu.

e Saving column name changes as the default for new projects now works correctly when set from
the worksheet.

e The Defaults button in the Column Configuration now restores the correct Primatech default
names.

DISPLAY
e Switching between Alternate and Standard in the display setup is now correctly detected as a
modification so that this change can be saved.
Folders are now displayed correctly on the Display page.
Changing the fonts for the column headings is now detected correctly and the header area will be
resized if necessary.
FIND /7 REPLACE

e You can now Find and Replace using spaces and symbols.

GUIDEWORDS

e If you change the relevance of a guideword, you are now prompted concerning the change.



PHAWorks 5.03 CHANGES cont. (ITEMS IN RED ARE NEW FEATURES):

LIBRARY

e The size limit for project notes has been increased to nearly 64K.
NAVIGATION

e Top of project and End of Project are now listed in the accelerator list.
PROGRAM

e International character support now works correctly.
e Close Protocol, Close Library, Close Project Notes, and Close Analysis Tools have been added to
the File menu.

PROJECT NOTES

e The size limit for project notes has been increased to 64K.
QUICK ACCESS

e Quick Access (Ctrl+A) has been added to the worksheet function menu.
QUICK COPY

e Parent entries in the Quick Copy dialog now include vertical scroll bars.
QUICK ENTRY

e You are no longer prompted to go into edit mode every time you access global quick entry lists.



PHAWorks 5.03 CHANGES cont. (ITEMS IN RED ARE NEW FEATURES):
REPORTS

e Creating PDF files now works correctly under Windows 95, 908 and Me.

o PHAWorks will not allow you to create a report if a worksheet banner is larger than one page.

e Under Windows 95, 98, Me, printing and preview work correctly for long reports. In prior versions
the program would use too many resources and this would eventually cause errors in the output.

e User defined report columns now work correctly with Classification, Statistical, and Risk Statistical
reports.

e When you page backwards in a preview of a Classification or Individual report, the first

worksheet is now filtered correctly.

When printing filters on the cover page using a non-default font, the list is now spaced correctly.

Printing a report in Landscape mode from the preview mode remembers the orientation setting.

When possible, HTML report files include the hyperlinks.

In the statistical report, if the value selected has multiple entries (e.g., multiple Cause Categories

for a single Cause), a statement indicating this is printed on the report.

e In the Individual Action Items and Individual Information Needs reports, the data for the first
person is now displayed correctly.

e Creating PDF files in landscape mode now works correctly.

e During the creation of a HTML file, the file name is now displayed correctly in the Print Status
dialog box.

e Browsing for the name of a PDF file now works correctly.

RISK RANKING

¢ Notes are now saved in the risk ranking files.
e The default risk ranking (DEFAULT.RR and PTRISK.RR) include the default description of
PHAWorks default.

SYMBOLS

e The Insert Symbol feature allows you to insert any character or symbol at your current editing
position. You can access Insert Symbol from the Edit menu, the worksheet shortcut menu, or the
shortcut menu for any edit field.
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PHAWorks 5.02 CHANGES (ITEMS IN RED ARE NEW FEATURES):
ACCELERATORS

e >From a command in the Help menu and a button within the Accelerator Configuration page of
the Option dialog, you can now view and print a listing of the currently assigned accelerator keys.

ASSOCIATIONS

e EVALUATION COPY - The installation program and the PHAWorks evaluation copy no longer
create associations between PHAWorks project file extensions and the evaluation program in the
registry.

e VIEWER - The installation program now includes a choice to create associations between
PHAWorks project file extensions and the program. The PHAWorks Viewer no longer creates
associations between PHAWorks project file extensions and the program.

BANNER NAMES

e PHAWorks 5.02 correctly reads banner names created in PHAWorks 4.x projects.
e The banner field names save as default for new projects option works correctly.

GUIDEWORD DIALOG

e The Show All option now works correctly for HAZOP projects.
HELP

e Running the PHAWORKF.EXE file will now locate and use the correct help file.
LIBRARY

e PgUp and PgDn now work correctly when located on the first or last page of a topic.
e Ctrl+PgUp and Ctrl+PgDn now move the cursor to the beginning or end of a topic in the library.

MISCELLANEOUS

e Human Factors and Facility Siting are now included in the general parameter list.

e Relevant Guidewords for Composition are now No, More, Less, As Well As, Part Of, and Other
Than.

¢ In the Change Project Association dialog, the description text is no longer limited to two lines.

e Pasting data within PHAWorks and from other products now works correctly.

NODE DIALOG

Entering a node intention will display an open square next to the node.

Entering a node note no longer displays a solid square next to a node.

Adding/deleting a node intention will display/remove the open square next to the node.

If a parameter has an open square displayed, this will cause an open square on the node.



PHAWorks 5.02 CHANGES cont. (ITEMS IN RED ARE NEW FEATURES):
NODE INTENTION DIALOG

e While proceeding through the dialogs, clicking back after entering the node intention now saves
the data.

NODE / SYSTEM / SUBSYSYSTEM / PARAMETER DIALOGS

e Checking the review checkboxes no longer displays an open square next to the node / system /
subsystem / parameter.

OPEN DIALOG
e The Project ID / Archive buttons now display correctly when running under W95.
PARAMETER DIALOG

Entering a parameter intention will display an open square next to the parameter.
Entering a parameter note no longer displays an open square next to a parameter.

e Adding/deleting a parameter intention will display/remove the open square next to the
parameter.

o |f a parameter has an open square displayed, this will cause an open square on the node.

PARAMETER INTENTION DIALOG

¢ While proceeding through the dialogs, clicking back after entering the parameter intention now
saves the data.

PROJECT IDENTIFICATION DIALOG

e When printing the Project Identification, the PHA Type and PHA Method fields are now included.
e When copying the Project Identification information to the clipboard, the "Process" field is now
included.

PROJECT NOTES

e PgUp and PgDn now work correctly when on the first or last page of the Project Notes.
e Ctrl+PgUp and Ctrl+PgDn now move the cursor to the beginning or end of the project notes.

QUICK COPY
e In Quick Copy, a list of recently accessed files is available.

e When copying between different project types in which one project was a HAZOP study, the
Causes column is now available under Quick Copy.



PHAWorks 5.02 CHANGES cont. (ITEMS IN RED ARE NEW FEATURES):

QUICK ENTRY

e Pasting into the Quick Entry dialog now works correctly.

e The browse button (...) for Quick Entry lists is now always displayed. If no Quick Entry lists are
available when this button is pressed, a message will be displayed.

e When accessing filters, the choice to create a Global Quick Entry list (if not used) no longer
appears.

e Global Quick Entry lists created in PHAWorks 4.x now work correctly in PHAWorks 5.02.

REPORTS

e Printing the date on the cover page is now optional.

e The options of Include Node number in Reference Number and Restart Reference Number for
Each Node no longer exist in the Action Items, Information Needs, Individual Action Items,
Individual Information Needs, and User reports. With the addition of the REF column, these
options were no longer required and were not used.

e Print preview and printing now works correctly on large reports under all operating systems.

e Selecting only Print cover page now prints the cover page even if no items are included on it.

REFERENCES
e Forward referencing now works correctly.

e The Create Reference dialog remembers the last selected choice (e.g. - Same As, Refer to).
e References typed directly into the worksheet now use the correct case.

REVALIDATION

o When revalidating a compatible project and selecting REPLACE/REDO, the PHA Method now
reflects the method chosen.

SAGE
e In Sage (Add a Component dialog), the Qualifier and ID fields now use combo boxes to
remember previous entered data.
e Pasting into the Sage dialog now works correctly.

SUBSYSTEM DIALOG

e The Subsystems dialog now includes an option not to use subsystems for the selected system.

WORKSHEET
e An hourglass cursor displays when pasting data into the worksheet.
e The S/L pop-up legends now use the worksheet font.
e You are now able to enter international characters in the worksheet.
e In the worksheet title bar, a label for the secondary level (e.g., Subsystem, Parameter) is now

included: Project file name: Node Number, <parameter label>: Parameter name



PHAWorks 5.02 CHANGES cont. (ITEMS IN RED ARE NEW FEATURES):

WORKSHEET VIEWS
o Worksheet Views is now a choice in the Copy from other project command.

e The Worksheet Views dialog now includes an option to save the settings as the default for new

projects.
e Worksheet Views is now in the Project Task Center.

USER DEFINED COLUMNS

e Filters now work for user-defined columns.
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PHAWorks 5.01 CHANGES (ITEMS IN RED ARE NEW FEATURES):
AUTOMATIC NUMBERING

e Restarting node numbering now works correctly.
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